Topic: Problem finding compiler ...

Hi everyone,

When launching the configure script : ./configure --enable-iml --enable-oofeg --enable-dss --enable--debug

I get this output :

loading cache ./config.cache
checking host system type... i686-pc-linux-gnu
checking for c++... no
checking for g++... no
checking for gcc... gcc
checking whether the C++ compiler (gcc  ) works... no
configure: error: installation or configuration problem: C++ compiler cannot create executables.

No way to go any further...I checked and the compiler seem to be correctly installed: I'm under Ubuntu 7.10
I've already installed other packages with gcc so i don't understand...
Thanks for the help smile


Re: Problem finding compiler ...


the gcc package contains only plain c compiler. To install C++ compiler, look for package called g++.
Install also libstdc++ (standard c++ library) if not installed with g++ automatically.

With best regards,

Re: Problem finding compiler ...

It worked well with 1.7 but now I tried 1.8 and got the following error at the end of the configure script :

Ckit includes not found in .
Type in directory (use absolute path):
I don't understand because I reached to install oofeg with 1.7 and for 1.8 I didn't change the file organisation


Re: Problem finding compiler ...

version 1.8 comes with new configuration procedure and there is no default directory for Ckit installation, as it was in 1.7

Use --with-CKITDIR=dir and --with-ELIXIRDIR=dir configure options
to specify location of Ckit and Elixir installation directories.


Re: Problem finding compiler ...

Oh I skiped this info in the readme file, thanks a lot smile

Re: Problem finding compiler ...

The configure script is now ok, but when trying to compile, it doesn't seem to really look in the right directory for the Elixir which it should find Esimple.h ...

  g++ -MM -I/home/xmaurice/Bureau/OOFEM/oofem-1.8/targets/oofem-debug/include      -I. -I../Elixir/include  -D__OOFEG -D__OOFEMLIB_MODULE -D__SM_MODULE -D__TM_MODULE -D__FM_MODULE /home/xmaurice/Bureau/OOFEM/oofem-1.8/src/oofemlib/constantsurfaceload.C | sed 's|\(constantsurfaceload\)\.o[ :]*|\1.o constantsurfaceload.d : |g' > constantsurfaceload.d; \
        [ -s constantsurfaceload.d ] || rm -f constantsurfaceload.d
Dans le fichier inclus à partir de /home/xmaurice/Bureau/OOFEM/oofem-1.8/src/oofemlib/domain.h:57,
          à partir de /home/xmaurice/Bureau/OOFEM/oofem-1.8/src/oofemlib/femcmpnn.h:55,
          à partir de /home/xmaurice/Bureau/OOFEM/oofem-1.8/src/oofemlib/generalbc.h:44,
          à partir de /home/xmaurice/Bureau/OOFEM/oofem-1.8/src/oofemlib/load.h:44,
          à partir de /home/xmaurice/Bureau/OOFEM/oofem-1.8/src/oofemlib/boundaryload.h:42,
          à partir de /home/xmaurice/Bureau/OOFEM/oofem-1.8/src/oofemlib/constantsurfaceload.h:42,
          à partir de /home/xmaurice/Bureau/OOFEM/oofem-1.8/src/oofemlib/constantsurfaceload.C:38:
/home/xmaurice/Bureau/OOFEM/oofem-1.8/src/oofemlib/oofeggraphiccontext.h:61:21: erreur: Esimple.h : Aucun fichier ou répertoire de ce typ

Re: Problem finding compiler ...

In fact when the problem is that when we run the configure script the path to the lixir dir and Ckit dir is not the same from the oofem directory (where we specify those paths for the configure script) and from the targets directory : from where the makefile is executed so it's certainly an error in the file architecture


Re: Problem finding compiler ...


you should use absolute path when using  --with-CKITDIR=dir and --with-ELIXIRDIR=dir directives. This will solve the problem.
This is also partly my error, this should be emphasized in README, I will fix this. Thank you.